解决 vue cli4 安装sass后,一写lang= "scss"就报错 __Vue.js
发布于 1 个月前 作者 banyungong 218 次浏览 来自 分享
粉丝福利 : 关注VUE中文社区公众号,回复视频领取粉丝福利

我用”npm install node-sass --save“ ”npm install sass-loader --save"下载的sass依赖,默认下载的就是 最新版,然后一写lang=“scss” ,就跑不成功,就报错。

后来百度了各种方法,都不行

然后我就把版本降低了,直接在pack.json里手动改了"node-sass": “^4.11.1”,

“sass-loader”: “^7.3.0”,然后把node-modules文件夹删除,重新npm install  ,重新启动就不会再报错了。

后来看了一篇文章说:原来node-sass和sass-loader有版本对应关系 安装的版本不对 就跑不起来

附上文章链接,想要了解的伙伴可以看一下

https://blog.csdn.net/qq_38505969/article/details/109788391

版权声明:著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。 作者: babybaby 原文链接:https://juejin.im/post/6926347150855143431

回到顶部