关于 vue 的构建版本和 webpack 打包的问题
发布于 2 个月前 作者 clubadmin 264 次浏览 来自 问答
粉丝福利 : 关注VUE中文社区公众号,回复视频领取粉丝福利

当使用 vue-loadervueify 的时候, *.vue 文件内部的模板会在构建时预编译成 JavaScript。你在最终打好的包里实际上是不需要编译器的,所以只用运行时版本即可。

字面上说,当使用 webpack (包含 vue-loader) 进行打包时,最后的项目,只需要【运行版本】就可以运行了。

但是,如果在 main.js 中不使用包含“编译器”的 vue.js 时,却出现如下的错误。

可能我对这个说明理解偏了。有谁可以解释下么。

2 回复

main.js:

new Vue({
  render: h => h(App)
})

感觉我还得进一步学习呢 :flushed:

回到顶部